jump to navigation

Installare driver ati 8.1 su Ubuntu 21 gennaio 2008

Posted by melchiorre in Guide, Ubuntu.
Tags: , , , ,
trackback

Aggiornamento:

Ho aggiornato questa guida, usate questa qui nel collegamento, non questa sotto.

Sono usciti da pochi giorni i nuovi driver Ati (i proprietari fglrx) per linux. Questi, oltre ad avere alcune migliorie rispetto ai precedenti (i 7.12, che sono, secondo me, da dimenticare) inroducono finalmente il supporto ufficilale ad Ubuntu, in particolare all’ultima release, ossia ubuntu 7.10 gutsy.

Installarli è divenuto molto semplice anche con l’installer grafico, senza i problemi precedenti e senza dover creare prima i pacchetti dall’installer.

Ecco una guida veloce e spero efficace, vista la mia ottima esperienza rispetto alle difficoltà nell’installare le versioni del driver precedenti sulla mia x1600pro sapphire.

Innanzitutto vi serve una scheda compresa nelle release notes:

È compresa? bene andiamo avanti.

Passo 1:
Scaricare nella vostra home o dove volete i nuovi driver da questo LINK

Passo 2:
Disinstallare i vecchi driver proprietari (se li avete installati in precedenza):
Da synaptic (o adept se avete kubuntu) cercate i pacchetti che contengono nel nome fglrx e disinstallateli.

Passo 3:
Dal terminale (Applicazioni -> Accessori -> Terminale) nella cartella in cui avete scaricato i driver (se sono nella home ci siete non appena aperto il terminale) date questo comando:
sudo sh ./ati-driver-installer-8-01-x86.x86_64.run
Comparirà l’installer grafico.
Scegliete l’opzione di installare i pacchetti, quindi accettate la licenza, per finire scegliete, se non avete particolari esigenze, l’opzione automatic. I driver si installeranno rapidamente sulla vostra ubuntu.

Passo 4:
Di default i driver proprietari ati non attivano il composite, per cui mettiamolo a mano.
Sempre da terminale date il comando (se avete kubuntu mettete kate al posto di gedit):
sudo gedit /etc/X11/xorg.conf
Comparirà un file di testo con le varie del vostro monitor, sceda grafica, eccetera.
Voi cercate la sezione:

Section “Extensions”
Option “Composite” “0”
Endsection

e prima di queste tre righe, e solo queste, mettete un # per riga, con un risultato simile a questo:

#Section “Extensions”
# Option “Composite” “0”
#Endsection

Così abbiamo commentato il comando che disabilità il composite, ossia il supporto grafico agli effetti del desktop 3D come compizfusion.
Salvate il file, e riavviate (a volte basta riavviare X, ma per sicurezza riavviamo tutta la macchina :P)
Entrate nel desktop e da terminale date il comando:
fglrxinfo
Se comparirà una schermata tipo questa:
mario@ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series
OpenGL version string: 1.4 (2.1.7276 Release)

mario@ubuntu:~$

i driver sono installati correttamente.

Per disinstallarli la via più veloce è quella del terminale, basta dare questo comando

sudo sh /usr/share/ati/fglrx-uninstall.sh

Fatemi sapere se è andato tutto bene.
Alla prossima

Commenti»

1. raymonde - 22 gennaio 2008

Li hai provati? I precedenti erano delle mezze schifezze. Al momento mi tengo i 7.10, funzionano bene. Mai provato Envy?
Ciao!
Ray

2. melchiorre - 22 gennaio 2008

Sì, envy l’ho provato, ma lo considero ottimo per le versioni precedenti dei driver, quando si doveva pacchettizzare i driver e ubuntu non era supportato ufficialmente da Ati, per cui l’installazione era difficile e spesso e volentieri l’intaller grafico faceva “cilecca”, come si dice dalle mia parti.
Con gli 8.1 tutti questi problemi si sono risolti e l’installer oltre ad essere velocissimo non mi ha creato problemi sulla mia “ostica” x1600, dove anche envy aveva fallito (ma non è colpa di envy, ma proprio dei driver della ati, che envy usa, ricordo che envy è un sistema automatizzato di script che segue il procedimento di installazione meccanicamente al posto nostro, per cui se l’installer fa pena, il povero envy non ci può fare nulla).

3. bird92 - 23 gennaio 2008

io ho dovuto disinstallare tutto… perchè quando avviavo mi davo lo skermo nero.. mi era successo anke per quelli precedenti..ma li era xkè non ero riuscito ad installare un pakketto poi ho rispolto ma adesso??? conoscete un altro modo?? potete contattarmi a: thebird92@gmail.com ??? grazie tanto in anticipo

4. melchiorre - 23 gennaio 2008

Tanto per sapere, che scheda video usi?

5. m4rC0 p4 - 23 gennaio 2008

ho provato anche io questi driver.

Risulta tutto installato correttamente (strano dato che e’ la prima volta che provo driver con supporto aiglx XD)

Un solo problema: le animazioni di compiz risultano parecchio “scattose” (es: minimizza/deminimizza). A te da lo stesso problema? Te lo chiedo perche’ anche io ho una scheda video della stessa serie (Ati X1650)

Grazie per l’aiuto🙂

6. melchiorre - 23 gennaio 2008

Allora, se usi le impostazioni di ubuntu non sono scattose, mentre se usi quello personalizzato alcuni plugin sono moooolto lenti

7. bear - 23 gennaio 2008

ciao a a tutti!
scusate ma da fglrxinfo risulta:

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: http://www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

cosa significa?grazie!

8. melchiorre - 23 gennaio 2008

mhhh allora non ha funzionato, per caso hai il pacchetto build-essential e hli header del kernel installati? se no installali🙂

9. bear - 23 gennaio 2008

si ho installato tutto!
ma cosa vuol dire che ho i driver mesa?

10. melchiorre - 23 gennaio 2008

Sono i driver generici, qualcosa non ha funzionato, la questione si fa complessa e coi nuovi driver è difficile fallire, ti consiglio di visitare il forum di ubuntu-it,lì io e altri ubuntiani ti sapremo aiutare nello specifico ecco il link
http://forum.ubuntu-it.org

11. STE - 23 gennaio 2008

anche io ho lo stesso prolema:

display: :0.0 screen: 0
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 7.0.1
Cosa significa?

12. razor46ultra - 23 gennaio 2008

mi spiace ragazzi… ma l’extension composite penso che vada abilitata, almeno a me funziona abilitandola non commentandola.
in ogni caso ho HD2400 sul portatile e compiz fusion và una veraviglia, ormai i nuovi driver vanno benissimo!😉
non è merito della mia distro…. uso debian😉

13. melchiorre - 23 gennaio 2008

L’extension composite in ubuntu è di default, quindi quella parte di xorg.conf è in più; in debian non è di default

14. bird92 - 24 gennaio 2008

scusate..ma ripropongo il mipo problema…
ho una ati radeon x1600… come mai seguendo alla lettera questa giuda (spero) non invia segnali al monitor dopo??? help please!!!
grazie in anticipo…😄

15. melchiorre - 25 gennaio 2008

Vai qui
http://forum.ubuntu-it.org/
lì abbiamo più spazio e tempo per risolvere i problemi tecnici

16. Compiz-switch: disattivare e attivare compiz in mezzo secondo « Melchiorre’s Weblog - 25 gennaio 2008

[…] compiz, compiz-switch, fglrx, googleearth, intel, xv trackback Avete una scheda video ati con i driver proprietari o una intel ed avete i tristemente noti problemi con la riproduzione video o applicazioni che […]

17. gotham - 26 gennaio 2008

due domande :
ho una x1950pro, non avevo installato nessun driver in precendenza quindi sono partito dal punto 3( spero sia giusto, oppure dovevo cmq rimuove qualcosa??)
ho seguito la guida ma nel filoe di xorg non trovo quelle voci nels enso che non sono presenti( strano???), da ultimo ho installato il pacchetto build-essential ma l’altro che chiami ” hli header del kernel” non lo trovo (??). spero in unj aiutino grazie.

18. melchiorre - 28 gennaio 2008

Allora, se non hai file fglrx già installati non puoi disinstallarli, quindi va tutto bene.
Per gli header basta che installi da synaptic il pacchetto: linux-headers-generic

19. Flameclaw - 28 gennaio 2008

anche io ho una X1600 da 512 ma il sistema ne rileva solo 128……come posso fare???? grazie mille

20. melchiorre - 28 gennaio 2008

Stesso problema, è un bug di questa versione dei driver

21. Top Drivers Blog » Blog Archive » Installare driver ati 8.1 su Ubuntu - 7 febbraio 2008

[…] Nastase: […]

22. Gigi - 10 febbraio 2008

ciao a tutti, ho appena installato Ubuntu 7.10 ma aimè ho riscontrato grossi problemi col modem USB IPMDATACOM.

Inoltre non mi parte in compiz-fusion da PREFERENZE-ASPETTO-VISUAL EFFECT ,come mai?

P.s ho letto su alcuni siti che bisogna scaricare i driver, ma come posso se non possiedo nessun collegamento? Inoltre i simboli aschii tipo * come li eseguo ?
Grazie

23. Installare i driver ati 8.02: ecco la guida aggiornata « Melchiorre’s Weblog - 14 febbraio 2008

[…] ripropongo la guida scritta da me qui, aggiornandola a questa versione dei […]

24. Installare i driver ati 8.02: Ecco la guida aggiornata. « Sudoaptget’s Weblog - 15 febbraio 2008

[…] ripropongo la guida scritta da me qui, aggiornandola a questa versione dei […]

25. blitzx - 10 marzo 2008

Porca pupazzola!
Grazie infinite per la guida che è molto utile… però sono stato ore a capire il perchè l’installazione dal terminale non mi partisse: questa non è una riga standard “sudo sh ./ati-driver-installer-8-01-x86.x86_64.run”

I driver vengono pur sempre aggiornati e il nome cambia leggermente di volta in volta. Bisognerebbe specificare che il comando non deve essere scritto di sana pianta ma di controllare il nome del file da caricare.

Grazie sempre, ciao!🙂

P.S.= Sono un “newbie”, per chi è come me non fa molta attenzione a questi piccoli particolari, soprattutto che i sistemi Linux pretendono la massima precisione nell’agire (non che sia un problema!).

26. melchiorre - 10 marzo 2008

Ciao, non hai letto l’aggiornamento iniziale? Lì c’è l link al mio nuovo post con i comandi per i driver di febbraio🙂

27. cri - 9 aprile 2008

a me mi da questo errore…

sudo sh ./ati-driver-installer-8-01-x86.x86_64.run
sh: Can’t open ./ati-driver-installer-8-01-x86.x86_64.run

sai perchè?

28. melchiorre - 9 aprile 2008

semplice, hai scaricato i driver di marzo (03) ma vuoi installare quelli di gennaio (01).
Segui la guida aggiornata che ho linkato all’inizio🙂
ciao

29. thejocker - 17 aprile 2008

ciao cri i driver che hai scaricato spostali nella Home e poi dai il comando da terminale 😉

30. Ktalin00b - 24 ottobre 2008

we … ho sbagliato un’attimo a fare qualcosa penso …

avrei prima dovuto rimuovere i vecchi driver installati (quelli base) … installato i driver ati … rimossi i driver vecchi x ciò anche questi ATI … viene fuori un’altro problema …

non riesco a reisntallare i driver ATI … motivo …
BANALISSIMO CAZZO BANNALISSIMO

LA RISOLUZIONE DELLO SCHERMO E’ TROPPO PICCOLA … MENTRE LA FINESTRA DELLA ATI E’ ENORME … xD sto skizzando
non riesco a premere in nessuno modo Continua …

gia’ provato con TAB … però anche se becco il pulsante dopo non so cosa premere x andare avanti (funziona solo col mouse) …

premo ENTER … niente SPACE neanche …

STO SKIZZANDOOOOOOOOOOOOOOO …

p.s. non posso neanche reinstallare Ubuntu … motivo??

E L’UNICO SISTEMA OPERATIVO NEL PC … quindi …
devi installare windows e di seguito Ubuntu…

p.s. se saresti cosi gentile da mandarmi x email questi 2 driver ti bacio i piedi cazzo GIUROOOOOO … sto andando fuori di testa

la mia email è: bufnitza_cu2peu@ymail.it

Scheda Video: AGP SLOT ->Ati Radeon x1650 (256 Mb)
Scheda Audio: Realtek AC97

sono le uniche 2 cose di cui ho bisogno …
x favoooooooo xD mandami sto link dal quale scaricarli ….

TiVojObEnEEEEE xD
Aspetto tua risposta … cyaaaaaaa

31. Ktalin00b - 24 ottobre 2008

in parte ho risolto ho solo bisogno dei drivers

Audio e Video

(ho configurato da xorg.conf la risoluzione a caso … dopo mi e venuto fuori qualcosa di strambo e ho scelto la risoluzione massima che risulta essere 800*600 … )

aspetto i drivers prima di fare qualche altra cazzata…..

grasie ancora🙂

32. Ktalin00b - 24 ottobre 2008

RISOLTOOOOOOOOOOOOOO cazzo …. nn penso ci siano persone + contente di me xD

33. melchiorre - 26 ottobre 2008

Grande🙂

34. gaspare - 31 gennaio 2009

salve ho installato come detto ma quando scrivo nel terminale sudo gedit /etc/x12/xorg.conf esce un file vuoto che non mi fa salvare, l’operazione seguente è andata a buon fine. i driver installati son i 9.1 su una 4870

melchiorre - 31 gennaio 2009

Ciao, non è x11 ma è X11 con la x maiuscola

35. Lorenz_Keel - 15 febbraio 2009

scusa ma quella lista è aggiornata vero? io ho una radeon 9000 e nn l’ho vista quindi sono fregato vero? ti ho scritto tutto il mio probblema nell’altra gyuida collegata a questa pls rispondimi

36. Foster - 25 dicembre 2012

Time pieces can easily be bought on the internet or in person.

Leather straps and plain metal bands go best with office wear while the gem-studded watches are ideal for formal parties and other
elegant events. For example, the Tank Francaise Series is
a historical collection by itself.

37. insurance handbook for the medical office - 2 marzo 2013

It’s very trouble-free to find out any topic on net as compared to textbooks, as I found this post at this web page.

38. loan a book from my kindle - 18 marzo 2013

Hi, i think that i saw you visited my blog thus i came to “return the favor”.
I’m trying to find things to improve my web site!I suppose its ok to use a few of your ideas!!

39. loan a kindle book to a friend - 25 aprile 2013

WOW just what I was looking for. Came here by searching for top paw dog food storage container

40. loana meconnaissable - 20 giugno 2013

This is my first time pay a visit at here and i
am actually happy to read everthing at alone place.

41. anal sex - 18 luglio 2013

Hello, i think that i saw you visited my web site thus i came to “return
the favor”.I am trying to find things to improve my
web site!I suppose its ok to use some of your ideas!!


Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: