jump to navigation

Problemi con java in firefox di Ubuntu Intrepid Ibex? Ecco la soluzione 13 febbraio 2009

Posted by melchiorre in Guide, Ubuntu.
Tags: , , , ,
12 comments

Aggiornamento: Guida aggiornata a firefox 3.0.6

Se avete provato sulla vostra Intrepid Ibex 8.10 ad avviare in firefox un applicazione java, molto probabilmente un messaggio vi avrà avvisato che nessun plugin è installato, per poi consigliarvi di installare java… ma voi l’avete già installato!

Questo è dovuto ad un problema di collegamenti tra java e firefox. Per risolvere basta ricrearli in questo modo:

Fase preliminare:

Assicurarsi di avere installata java, se non l’avete fatto installate il pacchetto ubuntu-restricted-extras.

Poi da terminale date il comando:

sudo update-alternatives --config java

e scegliete la versione della Sun (nel mio caso /usr/lib/jvm/java-6-sun/jre/bin/java).

Passo 1:

Da terminale date il comando:

sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.10/jre/lib/i386/xawt/libmawt.so

(altro…)

Annunci

Installare i driver ati: ecco la guida aggiornata 14 febbraio 2008

Posted by melchiorre in Aggiornamento versione, Guide, Novità Programmi, Ubuntu.
Tags: , , , , , , , , ,
126 comments

Aggiornamento: ho aggiornato questa guida per ubuntu alla versione dei driver 8.11, cioè quelli di novembre. Vi ricordo che questa guida è testata su ubuntu, ma dovrebbe andar bene anche su tutte le altre distribuzioni.

Usciti ieri notte i nuovi driver ati, che risolvono alcuni (pochi a dir la verità) bug secondari molto fastidiosi; eccovi le release notes con i bug risolti.

Vi ripropongo la guida scritta da me:

Prima di iniziare:

Assicuratevi di avere installato questi pacchetti da synaptic, fondamentali per installare i driver ati:

  • build-essential
  • libstdc++5
  • dh-make
  • fakeroot
  • dkms

installate anche gli header del kernel in uso, dando da terminale (Applicazioni -> Accessori -> Terminale):

sudo apt-get install linux-headers-$(uname -r)

Assicuratevi anche che il pacchetto xserver-xgl sia disinstallato. Da terminale date un

sudo apt-get remove xserver-xgl

(altro…)